Anaesthetic devices ‘vulnerable to hackers’

The machines, which have been used by the NHS, were recently found to have a security vulnerability.
BBC News – Technology

SPECIALS DISCOUNT UPDATE:

Wal-Mart.com USA, LLC